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Today’s topics

• MD simulation of a peptide

• Modeling of the aqueous environment

• MD simulation of a peptide

– Exercise 1

• MD simulation of a protein

– Exercise 2

• Accelarating simulations

• Notes
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Generating a peptide (1)

1. Start UCSF Chimera

2. Choose “Tools” → “Structure Editing” → 
“Build Structure.”

3. Choose “Start
Structure” and
“peptide,”
put 14 A’s in
Peptide Sequence,
and click “Apply.”

3



Generating a peptide (2)

4. In the Add Peptide Sequence window, you can 

change backbone dihedral angles. Here, simply 

click “OK.”

5. A peptide structure appears in the

main window. Choose “Actions” 

→ “Atoms/Bonds” → “show” and

“Actions” → “Ribbon” → “hide.”

6. Choose “File” → “Save PDB” and

save the structure as “ala14.pdb”

on the Desktop.
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Assignment of force-field parameters

1. Choose “Tools” → “Structure Editing” → “AddH” 

and click “OK” to add hydrogens.

2. Choose “Tools” → “Structure Editing” → “Add 

Charge,” select “AMBER ff99SB” as the force 

field of the Standard residues, and click “OK.”

3. Choose “Tools” → “Amber” → “Write Prmtop” to 

save the parameter/topology file. Change the 

Folder to “C:¥Users¥student¥Desktop”, set the 

File name to “ala14,” select “AMBER ff99SB” as 

the force field type, and click “Save.”
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Procedure of MD simulation

1. Download namd2.exe and tcl85t.dll from the 

web page of this lecture and save them on 

the desktop.

2. Download ala14.zip from the web page of 

this lecture and save it on the desktop. 

3. Unzip ala14.zip by double-clicking it. Move 

ala14.prmtop and ala14.inpcrd to the 

generated folder, ala14.

4. Run run.bat by double-clicking it.
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Software

• NAMD

– Used here. Free.

– AMBER and CHARMM force fields are supported.

– http://www.ks.uiuc.edu/Research/namd/

• Gromacs

– Free.

– AMBER, CHARMM, GROMOS force fields are 

supported.

– http://www.gromacs.org/

• AMBER, CHARMM, etc.
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Visualizing the result (1)

1. Start Chimera. (If already running, choose “File” → 

“Close Session.”)

2. Choose “Tools” → 

“MD/Ensemble Analysis” →

“MD Movie.”

3. Select “NAMD (prmtop/DCD)”

as Trajectory format,

set ala14.prmtop to Prmtop,

add min.dcd, eq.dcd,

prod.dcd in this order to the list of the DCD files, and 

click “OK.”
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Visualizing the result (2)

4. Click the play button in the MD Movie 

window to watch the movie.

5. Choose “Actions” → “Atoms/Bonds” → 

“show” and “Actions” → “Ribbon” →

“hide” to change the representation to the 

stick model.

6. Watch the movement of the atoms.
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Calculating RMSD

1. Choose “Select” → “Atom Specifier,” put 

“@CA” in the textbox of Atom specifier to

select, and click “OK” to select Cα atoms.

2. Choose “Analysis” → “Plot” → “RMSD” 

from the menu of the MD Movie window.
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Measuring hydrogen-bond length

1. Choose “Analysis” →
“Plot” → “Distances” in 
the MD Movie window.

2. Click on one atom of 
the pair of interest and 
click on the other atom 
while pressing the Ctrl 
key.

– Use “distance.com” to 
find the atoms involved 
in the hydrogen bonds.

3. Click the “Plot” button in 
the MD Plots window.

11

In a helices, hydrogen bonds are 

formed between carbonyl oxygen of 

the i-th residue and amide nitrogen of 

the (i+4)-th residue.

Branden & Tooze “Introduction to Protein Structure” 2nd Ed.



Result of the simulation
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Modeling the aqueous environment (1)

• The simulation was performed in vacuum, 

and therefore the solvation effect by water 

molecules is not considered.

• When performing biomacromolecular

simulations, it is necessary to put the 

molecules in an aqueous environment.
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Modeling the aqueous environment (2)

• Explicit water model

– Place water molecules in a sphere

– Place water molecules in a rectangular box

→used under periodical boundary condition

• Implicit water model to approximate solvation free 

energy

– Non-polar term→proportional to solvent accessible surface 

area

– Polar term→continuum dielectric model

• Poisson-Boltzmann equation

• Generalized Born model
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Spherical placement
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• To prevent vaporization of the water molecules, a 

restraining force is applied to the water molecule going 

outside of the sphere of radius rcap.

• Surroundings of the water molecules near the surface of 

the sphere are different from those of the water 

molecules near the center of the sphere. 15
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Periodical boundary condition

• The central cell is replicated 

to form an infinite lattice.

• A molecule that goes out 

the cell enters through the 

opposite face.

• Molecules do not feel the 

boundary.

• The dimensions of the cell 

should be large enough to 

reduce the unnatural effect 

from neighboring cells.
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Calculation of pressure
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In a system of non-interacting particles (ideal gas), 

PV = NkBT = nRT
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Pressure regulation

• Pressure is regulated by changing the dimensions 
of the cell under the periodical boundary condition.

• Pressure can be negative.

P low

P highri αri

Center-of-mass 

positions of the 

molecules are scaled. 

The structure of each 

molecule does not 

change.
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Simulation in aqueous environment (1)

1. Start Chimera and open ala14.pdb.

2. Change the representation to sticks and add 

hydrogen atoms.

3. Choose “Tools” → “Structure Editing” → 

“Solvate.” Select “Box” as Solvate method and 

“TIP3PBOX” as Solvent Model, set Box size to 

“6,” and click “OK.”

4. Choose “Tools” → “Structure Editing” → “Add 

Charge.” Select “AMBER ff99SB” as the force 

field of Standard residues and click “OK.”
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Simulation in aqueous environment (2)

5. Choose “Tools” → “Amber” → “Write Prmtop.” 

Ensure the Folder is “C:¥Users¥student¥Desktop,” 

set File name to “ala14-wat,” select “AMBER ff99SB” 

as the force field type, and click “Save.”

6. Choose “File” → “Save PDB” to save the solvated 

structure as ala14-wat.pdb on the desktop.

7. Download ala14-wat.zip from the web page of this 

lecture, save it on the desktop, and unzip it.

8. Move ala14-wat.prmtop, ala14-wat.inpcrd, and 

ala14-wat.pdb to the ala14-wat folder.
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Simulation in aqueous environment (3)

9. Open the ala14-wat folder and run restraint.pl by 

double-clicking it to generate ala14-wat_rest.pdb.

10. Modify min1.in as follows:
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Open ala14-wat.inpcrd in 

WordPad and go to the last line.

Copy the cell 

dimensions.

Product of 2, 

3, and 5 close 

to the cell 

dimensions



Simulation in aqueous environment (4)

11.Run run.bat by double-clicking it to 

perform simulations in the following order 

(They will take about 3 minutes in total):

① Energy minimization (water only) (min1)

② Energy minimization (whole) (min2)

③ Equilibration (0→300 K) (eq1, 10 ps)

④ Equilibration (constant-NPT) (eq2, 10 ps)

⑤ Production (prod, 10 ps)
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Analysis of the result

1. Start Command Prompt (cmd) and 

execute the following commands:
> cd Desktop¥ala14-wat

> energy.pl eq1.log eq2.log prod.log

2. Open energy.csv in Excel.
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Reason for the volume change

• When water molecules are 

placed around the protein,  a 

block of equilibrated water is 

used to fill the cell and the 

water molecules overlapping 

with protein atoms are 

automatically removed. As a 

result, spaces are produced 

around the protein.

• During the constant-NPT

simulation, the water structure 

is optimized. As a result, the 

space is filled and the volume 

is decreased. Decrease of 

the volume

Spaces around 

the protein

24

Constant-NPT simulation

water



Exercise 1

• Plot the temperature (TEMP), pressure 

(PRESSURE), and volume (VOLUME) as a 

function of time during the equilibration runs (eq1 

and eq2) and the production run (prod).

– The time step Δt is 2 fs.

• Plot the variation of the Cα RMSD during the 

energy minimization (min1 and min2), equilibration 

runs (eq1 and eq2) and the production run (prod).

• What conclusions can you draw from these plots?
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Computational time (1)

• Target: water spheres (the TIP3P model)

• The Sander module of Amber 18 was used.

• 6 cores of an Intel Xeon Processor were used.

• The time step Dt was 0.5 fs.

• Computational time of a 1-ps simulation was measured.

*4.2 days per ns 26

#atoms Ttotal [s] Ratio Tnb [s] Tnb/Ttotal
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6066
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30.3

119.0
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11.9
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118.4
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Acceleration of simulation

• Use of a larger Dt

– The SHAKE method

– The multiple time step metod

• Approximation of non-bonded interactions

– The cut-off method

– The fast multipole method

– The particle mesh Ewald (PME) method
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The SHAKE method

• In general, 1/10 – 1/20 of the cycle of the 

fastest motion is appropriate to the time step.

• X–H bond stretching motion is the fastest.

→Cycle is about 10 fs→Δt = 0.5～1 fs

• X–X bond stretching motion is the second 

fastest.→Cycle is about 20 fs

• The SHAKE method fixes X–H bond lengths.

→Longer time step (Δt = 2 fs) can be used.
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An example (1)

-0.02

0

0.02

0.04

0.06

0.08

0.1

0.12

0.14

0 2 4 6 8 10

時間 [ps]

全
エ

ネ
ル

ギ
ー

の
誤

差
 [

kc
al

 m
o
l-

1
]

Time evolutions of the error in the total energy during 

the constant-NVE MD simulations of methanol

Without SHAKE (Dt = 1 fs)
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An example (2)

Without SHAKE

With SHAKE

The accuracy of the simulation with Δt = 2 fs and SHAKE is comparable 

to that of the simulation with Δt = 0.5 fs and without SHAKE. 30

A
v
e
ra

g
e
 a

b
s
o
lu

te
 e

rr
o
r 

[k
c
a
l 
m

o
l–

1
]

Time step Δt [fs]



Settings in NAMD (1)

• SHAKE is enabled by the following settings.
rigidBonds all

useGroupPressure yes

31



Calculation of non-bonded interactions

• Non-bonded interactions are calculated for 

pairs of atoms.

→N(N−1)/2 pairs in N-atom system

• Non-bonded interactions reduces as the 

distance between atoms increases. (Van der 

Waals attraction is proportional to r−6 and 

electrostatic interaction is to r−1.)

• Interactions between distant atoms are 

negligible.→the cut-off method
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The cut-off method

• Only the atoms within 

the radius of rc from 

atom i interact with 

atom i.

• Let the average 

number of atoms 

within this sphere be 

M. Then, the number 

of pairs reduces from 

N(N−1)/2 to NM.

rc
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Making pair list

• It is necessary to list atoms 

within the cut-off radius rc

for each atom.

• Computational cost is 

proportional to N(N−1)/2.

• To reduce the cost, a list of 

atoms within the distance of 

rl (rl > rc) is generated for 

each atom . This list is 

updated only when the 

displacement of an atom 

exceeds rl−rc.

rc

rl
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Periodic boundary condition (1)

• Under the periodic 

boundary condition, it 

is impossible to 

compute all the 

interactions without 

any approximation.
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Application of the cut-off method

• It is necessary to 

consider the atoms in 

the image cells 

neighboring to the 

central cell.

(In this case, 26N2+ 

N(N−1)/2 pairs must 

be considered.)

1

2

4

5
3

2
5

3
5

4

5

Lx

Ly

36



Minimum image convention

• When the cut-off 

radius is less than the 

half of the shortest 

dimension of the cell, 

the number of pairs 

that must be 

considered reduces to 

N(N−1)/2.

→minimum image 

convention
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Problem of the cut-off method

• Van der Waals interaction is 

proportional to r−6.

→It can be accurately 

calculated with the cut-off 

method.

• Electrostatic interaction is 

proportional to r−1.

→The cut-off method causes 

large errors.

• Because the energy changes 

discontinuously when an atom 

goes in or out the cut-off 

sphere, the total energy is not 

conserved.

r

1

6

1

r

Dt

No interaction Interaction
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Calculation without cut-off (1)

Interactions are calculated 

not only between the atoms 

in the central cell, but also 

between the atoms of the 

central cell and those of the 

image cells.

Electrostatic potential at r is 

given by,
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Calculation without cut-off (2)

• Under periodic boundary condition, the 

charge distribution can be expressed with 

a Fourier series.
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Calculation without cut-off (3)

• The 3D version:
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Calculation without cut-off (4)

• Solution of the Poisson equation
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The particle mesh Ewald method (1)

• nx, ny, and nz run from minus infinity to infinity.

• By discretizing r, the ranges can be narrowed.
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The particle mesh Ewald method (2)

• The charge distribution is made up of point charges.

→ In general, the point charges are not on the lattice.

→The distribution is convoluted with the Gaussian 

function.
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The particle mesh Ewald method (3)

• Difference from the original charge distribution

• Electrostatic potential is expressed as the sum of 

the electrostatic potential produced by the 

convoluted charge distribution and that produced by 

the residual charge distribution.

– =

Point charge
Convoluted 

distribution
Residual
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The particle mesh Ewald method (4)
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r–1

Large σ

Small σ

• In the residual distributions, charges with opposite signs 

surround the point charges.

→Electrostatic potential more steeply decreases than r–1.

→The interactions can be accurately calculated with the 

cut-off method.
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Computational time (2)

• Simulations were performed 

for water boxes and spheres. 

• Without approximation, 

computational time is 

proportional to N2.

• With PME, it becomes 

proportional to NlogN.

• SHAKE allows the use of 

four-times longer time step 

(2 fs). The computational 

speed becomes 3.8-times 

faster.

Without approximation

PME

PME+SHAKE
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Settings in NAMD (2)

• Use the following settings when using PME:
cutoff 10.0
switching off
cellBasisVector1 42.3810 0.0 0.0
cellBasisVector2 0.0 36.4706 0.0
cellBasisVector3 0.0 0.0 42.1148
PME yes
PMEGridSizeX 45
PMEGridSizeY 40
PMEGridSizeZ 45
extendedSystem XSC_file_name

• Write either of ★ or ☆.
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MD simulation of a protein (1)

1. Open a protein structure with PDB ID of 1CRN in 

Chimera.

2. Change the representation to sticks.

3. Add hydrogen atoms.

4. Solvate the protein in a rectangular box.

5. Add charges. Use “AMBER ff99SB” for the force 

field of standard residues.

6. Write parameters (prmtop) in files named 

“1CRN.” The force field is “AMBER ff99SB.”
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MD simulation of a protein (2)

7. Save the coordinates in a PDB file named “1CRN.pdb.”

8. Download 1CRN.zip from the web page of this lecture, 

save it on the desktop, and unzip it.

9. Move 1CRN.prmtop, 1CRN.inpcrd, and 1CRN.pdb to 

the 1CRN folder.

10. Run restraint.pl to generate 1CRN_rest.pdb.

11. Modify the cell dimensions in min1.in.

12. Run run.bat to start the simulations. (They will take 

about 8 minutes in total.)
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Exercise 2

• Plot the variation of the Cα RMSD.

• Plot the temperature (TEMP) and potential 

(POTENTIAL) as a function of time during 

the equilibration runs (eq1 and eq2) and 

the production run (prod).

– The time step Δt is 2 fs.

• What conclusions can you draw from these 

plots?
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Instructions for submission

• Put the results and discussion of the exercises in 

the slides of a PowerPoint file.

• Send the PowerPoint file as an attachment to email.

– Do not send the Excel files. They are too large!

• Put “Molecular modeling” in the Subject field.

• Be sure to put your name, ID card number (if you 

are a student), and registration ID (e.g. 18001) in 

the body of the email.

• Send the email to Prof. Tohru Terada 

(tterada@iu.a.u-tokyo.ac.jp).  

52


